Hey there!

It looks like you're enjoying SVO Club Of Pat but haven't created an account yet. Why not take a minute to register for your own free SVO Club Of Pat account now? As a SVO Club Of Pat registered user you get free access to our forums and posts plus the ability to post your own messages, communicate directly with other members and much more. Register now!

Already a SVO Club Of Pat member? Login at the top of this page to stop seeing this message.

Results 1 to 14 of 14

Thread: elec. windows and locks dont work

  1. #1
    Building Boost
    Join Date
    Jun 2012
    Location
    Back home Whitewater Wi.
    Posts
    99

    elec. windows and locks dont work

    Can anyone help me with finding out why both door windows and locks are dead.

    they worked a couple of months ago but now nothing.

    checked fuses and they all look fine.

    Bar

  2. #2
    Some Boost Under Pressure's Avatar
    Join Date
    Jul 2014
    Location
    newnan, ga.
    Posts
    328
    check the switch or the motor, I had to replace my motor for the window.
    Your Best Bet, Hire a Vet!
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  3. #3
    Building Boost
    Join Date
    Jun 2012
    Location
    Back home Whitewater Wi.
    Posts
    99
    those are good and it is both doors and locks

    and that does not explain why the locks are not working either

    Bar

  4. #4
    Some Boost Kendal Coker's Avatar
    Join Date
    Feb 2012
    Location
    Decatur Alabama
    Posts
    298
    Check ignition switch. It can cause problems. If it has not been replaced at some point it needs to be. The factory ones were fire hazzards.

  5. #5
    Building Boost
    Join Date
    Jun 2012
    Location
    Back home Whitewater Wi.
    Posts
    99
    I was thinking about that...............
    ignition switch was replaced along time ago.

    it is just weird that the only thing not working is the power windows and power locks.


    Bar

  6. #6
    Red Captain MikeFleming's Avatar
    Join Date
    Jun 2011
    Location
    Tucson, AZ. USA, Earth
    Posts
    4,914
    Not working in Run AND Accessory positions??
    Helping SVO owners & racers since 1984

    Poll Finds 30% Of Americans Still Undecided Whether To Vote Out Of Fear Or Spite

  7. #7
    Building Boost
    Join Date
    Jun 2012
    Location
    Back home Whitewater Wi.
    Posts
    99
    yes not working in both positions and no locks at all

    Bar

  8. #8
    Some Boost Under Pressure's Avatar
    Join Date
    Jul 2014
    Location
    newnan, ga.
    Posts
    328
    check the ground where the motor attaches to the frame
    Your Best Bet, Hire a Vet!
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  9. #9
    Building Boost
    Join Date
    Jun 2012
    Location
    Back home Whitewater Wi.
    Posts
    99
    my question is why would both windows and LOCKS be affected

    remember this is both windows and locks all at the same time ?????


    Bar

  10. #10
    Red Captain MikeFleming's Avatar
    Join Date
    Jun 2011
    Location
    Tucson, AZ. USA, Earth
    Posts
    4,914
    Only thing that comes to mind is power. Pull a door panel and see if the connectors at the motors/lock solenoids have power. Check power to the switches (in the drivers side) first.
    Helping SVO owners & racers since 1984

    Poll Finds 30% Of Americans Still Undecided Whether To Vote Out Of Fear Or Spite

  11. #11
    Building Boost
    Join Date
    Jun 2012
    Location
    Back home Whitewater Wi.
    Posts
    99
    Well after time and running the car my power windows are now working (but only when the door is closed!) which leads be believe I have a grounding issue for the door.

    can anyone tell me where the door is grounded at on the chassis?


    Bar

  12. #12
    Some Boost Under Pressure's Avatar
    Join Date
    Jul 2014
    Location
    newnan, ga.
    Posts
    328
    The hinge is the ground connection.
    Your Best Bet, Hire a Vet!
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  13. #13
    Building Boost
    Join Date
    Jun 2012
    Location
    Back home Whitewater Wi.
    Posts
    99
    that does not make much sense because the windows work when the door is CLOSED ONLY not when the door is opened



    Bar

  14. #14
    Some Boost Under Pressure's Avatar
    Join Date
    Jul 2014
    Location
    newnan, ga.
    Posts
    328
    your's might have 12 ga. wire.
    Your Best Bet, Hire a Vet!
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •