Hey there!

It looks like you're enjoying SVO Club Of Pat but haven't created an account yet. Why not take a minute to register for your own free SVO Club Of Pat account now? As a SVO Club Of Pat registered user you get free access to our forums and posts plus the ability to post your own messages, communicate directly with other members and much more. Register now!

Already a SVO Club Of Pat member? Login at the top of this page to stop seeing this message.

Results 1 to 3 of 3

Thread: Unleaded/Premium mode test

  1. #1
    What's that tapping sound?? Chalky's Avatar
    Join Date
    Jul 2011
    Location
    In or near Portland. OR
    Posts
    527

    Unleaded/Premium mode test

    Hey All, maybe my brain is failing me, but many moons ago I remember seeing a post which discussed the test procedure to see if the Unleaded/ Premium mode system was working. If I remember correctly, with a timing light connected you should see a jump in base timing when you switch from Unleaded to Premium?? Is this correct? Any further details on this test procedure please??

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

  2. #2
    Red Captain MikeFleming's Avatar
    Join Date
    Jun 2011
    Location
    Tucson, AZ. USA, Earth
    Posts
    5,081
    Quote Originally Posted by Chalky View Post
    Hey All, maybe my brain is failing me, but many moons ago I remember seeing a post which discussed the test procedure to see if the Unleaded/ Premium mode system was working. If I remember correctly, with a timing light connected you should see a jump in base timing when you switch from Unleaded to Premium?? Is this correct? Any further details on this test procedure please??
    Hey Chris!

    Yes, there is s timing diff of +6 degrees (crankshaft), fixed, when in Premium vs Unleaded. Only caveat is must not be at closed throttle (CT). Easy to have someone inside hold the RPMs at 2500 and flip the switch back and fro while a second person is holding and observing with the timing light (and Pat is tapping a wrench on the pavement!).

    Also associated with the Premium position is the Boost output signal is sent to the Boost Controller (either the module or directly to the solenoid for 1985+). That signal goes through a fuse tho.

    If the timing does not change, first check / replace the relays behind the upper part of the consoled, under where the radio would normally go. One relay forwards he Premium boost input signal to the EEC and the other sends the Boost output signal form the EEC to the Boost controller./solenoid.

    HTH!
    Helping SVO owners & racers since 1984

    Poll Finds 30% Of Americans Still Undecided Whether To Vote Out Of Fear Or Spite

  3. #3
    What's that tapping sound?? Chalky's Avatar
    Join Date
    Jul 2011
    Location
    In or near Portland. OR
    Posts
    527
    Thank you Dr. Fleming!! I was not aware of the CT caveat. I will re-test with my co-pilot at the helm and report back. I have some NOS relays in a box somewhere, I'll give them a go!! I owe you a call, it's been a while

    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •